The Debian builds are way out of date for squeeze (stable), depending
as they do on very old versions of postgresql-*-postgis (the current
and only version is postgresql-8.4-postgis), making them
Although I expect the existing Ubuntu/Lucid packages may "just work" on
Squeeze as the vintage of the packages in the two distros is rather
I plan build 2.11svn2556 not the latest svn because I miss the preview
window in the bottom left too much,and really I'm just building them for
myself :). (probably at some point I'll add a config option to swap that
preview box with the compass needle to 2.12svn)
If not already in the wiki I'll post the two or three commands you need
to run to generate the packages, e.g. if you want a newer gpsd from
- I'm not sure if the build cluster is operational, I just get a blank page.
this would all be moot if we could get a newer gpsdrive uploaded to Sid.
I don't think the files in the debian/ dir of the gpsdrive SVN are in
such bad shape, but it's been a while since I've run lintian on them.
Not sure how to proceed on that task or how/where to unjam the logs.
Any advice Paul?
One thing I'd like to do is get the Natural Earth world boundaries
uploaded to Debian/main (CC-PD or so) so we can Recommends that and
have Mapnik+PostGIS rendering as an out-of-the-box option. I think the
300mb+ world_boundaries shapefiles will always be too big.
I've already got that working on the OSGeo LiveDVD/VM where space is
Also (and more a task for DebianGIS than GpsDrive but worth mentioning),
I'd very much like to have GMT, ZyGRIB, Xtide, and OpenCPN all use the
same GSHHS world coastline package instead of each using a variant/
duplicate of the same dataset. Due to the hierarchical needs of those I
think the NaturalEarth shapefile (which Mapnik requires) won't do for
> I see that your version is dependent on libgps19 (>= 2.90.1~svn6819).
> Will it work with the gpsd HEAD, currently at libgps.so.20?
> Also, is there any way to install your package without pulling in that
> dependency (currently 2.94-2 and dependent on libgps19)? I use gpsd
I expect you'll have to rebuild the package yourself, but that's just a
2-liner or so.
> The Debian builds are way out of date for squeeze (stable), depending
> as they do on very old versions of postgresql-*-postgis (the current
> and only version is postgresql-8.4-postgis), making them
I didn't see that the Buildcluster ran out of discspace. It's fixed now and you should be able to get dome debian packages from there again.
If anyone has fixes which make it compile on one of the versions which are marked red; please post/svn-ci them.